ZOJ2965 Accurately Say "CocaCola"! java

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2965

                            Accurately Say "CocaCola"!

In a party held by CocaCola company, several students stand in a circle and play a game.

One of them is selected as the first, and should say the number 1. Then they continue to count number from 1 one by one (clockwise). The game is interesting in that, once someone counts a number which is a multiple of 7 (e.g. 7, 14, 28, ...) or contains the digit '7' (e.g. 7, 17, 27, ...), he shall say "CocaCola" instead of the number itself.

For example, 4 students play this game. At some time, the first one says 25, then the second should say 26. The third should say "CocaCola" because 27 contains the digit '7'. The fourth one should say "CocaCola" too, because 28 is a multiple of 7. Then the first one says 29, and the game goes on. When someone makes a mistake, the game ends.

During a game, you may hear a consecutive of p "CocaCola"s. So what is the minimum number that can make this situation happen?

For example p = 2, that means there are a consecutive of 2 "CocaCola"s. This situation happens in 27-28 as stated above. 27 is then the minimum number to make this situation happen.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 100) which is the number of test cases. And it will be followed by T consecutive test cases.

There is only one line for each case. The line contains only one integer p (1 <= p <= 99).

Output

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the minimum possible number for the first of the p "CocaCola"s stands for.

Sample Input

2
2
3

Sample Output

27
70

题意:

求连续n个与7有关的数字,(整除7或者数字里含有7(例如17))。

思路:

暴力解。

代码:

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			int t=sc.nextInt();
			for(int i=0;i<t;i++){
				int p=sc.nextInt();
				int index=0;
				int count=0;
				for(int j=7;;j++){
					if(p==index){
						count=j-p;
						break;
					}
					if(isCondition(j)){
						index++;
						continue;
					}
					index=0;
				}
				System.out.println(count);
			}
		}

	}
	static boolean isCondition(int i){
		if(i%7==0){
			return true;
		}
		while(i!=0){
			if(i%10==7){
				return true;
			}
			i/=10;
		}
		return false;
	}
}

猜你喜欢

转载自blog.csdn.net/coding_lin/article/details/81096024