blockhouses(dfs)

blockhouses

时间限制:1000 ms  |  内存限制:65535 KB

难度:3

输入

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

输出

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

样例输入

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

样例输出

5
1
5
2
4

来源

2012年10月份月赛(高年级组)

上传者

ACM_丁国强

描述

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

题意:给你一个城市,要在城市里架炮,炮能向前后左右四个方向发射,要使两炮不能被对方轰炸,墙可以阻挡炮弹,问最多能放多少炮。

思路:枚举每一个位置放或不放炮,关键是怎么来枚举每个位置,通过一个计数的变量pos来定义位置,pos/n表示行,pos%n

表示列,然后判断该位置能不能放炮。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
#include<math.h>
#include<iostream>
#include<map>
#include<vector>
#include<stack>
#include<queue>
using namespace std;
#define LL long long
const int N=5;
char a[N][N];
bool vis[N][N];
int n,ans,s;
bool check(int x,int y)
{
    if(vis[x][y]||a[x][y]=='X') return false;
    int tx=x;
    while(x>=0)
    {
        x--;
        if(a[x][y]=='X') break;
        if(vis[x][y]) return false;
    }
    x=tx;
    while(y>=0)
    {
        y--;
        if(a[x][y]=='X') break;
        if(vis[x][y]) return false;
    }
    return true;
}
void dfs(int pos,int sum)
{
    if(pos==n*n)
    {
        ans=max(sum,ans);
        return ;
    }
    int row=pos/n,col=pos%n;
    if(check(row,col))
    {
        vis[row][col]=true;
        dfs(pos+1,sum+1);
        vis[row][col]=false;
    }
    dfs(pos+1,sum);
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        ans=s=0;
        memset(vis,false,sizeof(vis));
        for(int i=0;i<n;i++)
            scanf("%s",a[i]);
        dfs(0,0);
        printf("%d\n",ans);
    }
}

别人的代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n,vis[6][6],maxx;
char map[6][6];
int check(int x,int y)
{
    int i;
    if(vis[x][y]!=0) return 0;
    //四个方向
    for(i=x-1; i>=0; i--)
    {
        if(vis[i][y]==1)
            break;
        else if(vis[i][y]==2)
            return 0;
    }
    for(i=x+1; i<n; i++)
    {
        if(vis[i][y]==1)
            break;
        else if(vis[i][y]==2)
            return 0;
    }
    for(i=y-1; i>=0; i--)
    {
        if(vis[x][i]==1)
            break;
        else if(vis[x][i]==2)
            return 0;
    }
    for(i=y+1; i<n; i++)
    {
        if(vis[x][i]==1)
            break;
        else if(vis[x][i]==2)
            return 0;
    }
    //printf("OK %d %d+",x,y);
    return 1;
}
int DFS(int deep)
{
    for(int i=0; i<n; i++)
    {
        for(int j=0; j<n; j++)
        {
            if(check(i,j))
            {//printf("已经确认一个\n");
                vis[i][j]=2;//2 炮塔
                DFS(deep+1);
                vis[i][j]=0;
               // printf("已经删除一个\n");
            }
        }
    }
    if(deep>maxx)
        maxx=deep;
    return maxx;
}
int main (void)
{
    while(~scanf("%d",&n),n)
    {
        //memset(map,0,sizeof(map));
        memset(vis,0,sizeof(vis));
        getchar();
        //printf("11");
        for(int i=0; i<n; i++)
        {
            for(int ii=0; ii<n; ii++)
            {
                scanf("%c",&map[i][ii]);
                if(map[i][ii]=='X') vis[i][ii]=1;//1 强,这里输成小写x,查错好久
            }
            getchar();
        }
        maxx=0;
        printf("%d\n",DFS(0));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Never__give__up/article/details/81103117
dfs