坦克大战 nyoj 284(优先队列+广搜)

坦克大战

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now.
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).

Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
输入
The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
输出
For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.
样例输入
3 4
YBEB
EERE
SSTE
0 0
样例输出
8
来源
POJ
上传者
sadsad

题意:‘Y’代表起点,‘T’代表终点,‘E’代表空地,‘R’和‘S’不能通过,‘B’代表砖,可以打烂后变成空地,打烂需要花费一秒,问从起点到终点花费的最少时间。

题解:看到这道题,感觉挺简单的,思路是每次搜到‘B’时都让他在原地等待一秒然后再让他前进,然后按照这一思路写了一下,wa了,想不明白哪里有错,搜了下题解,他们都用到了优先队列,然后再一想,每次都把最小的时间弹出来搜索,这样搜到的结果肯定是最小的,至于为什么我的会错,是因为我的思路只能处理当前这一步的优先级,即遇到‘B’时等待一秒再进行搜索,这样就不能保证每次出队的节点的时间最少。

正确代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
const int N=303;
char a[N][N];
int m,n,dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
bool vis[N][N];
struct node
{
    int x,y,time;
    friend bool operator <(const node &p,const node &q)
    {
        return p.time>q.time;
    }
}now,net;
bool can(int x,int y)
{
    if(x<0||x>=m||y<0||y>=n||vis[x][y]||a[x][y]=='R'||a[x][y]=='S')
        return false;
    return true;
}
void bfs()
{
    memset(vis,false,sizeof(vis));
    priority_queue<node>q;
    q.push(now);
    vis[now.x][now.y]=true;
    while(!q.empty())
    {
        now=q.top();
        q.pop();
        for(int i=0;i<4;i++)
        {
            net=now;
            net.x+=dir[i][0];
            net.y+=dir[i][1];
            if(can(net.x,net.y))
            {
                if(a[net.x][net.y]=='B')
                {
                    net.time+=2;
                    vis[net.x][net.y]=true;
                }
                else
                {
                    net.time++;
                    vis[net.x][net.y]=true;
                }
                if(a[net.x][net.y]=='T')
                {
                    printf("%d\n",net.time);
                    return ;
                }
                q.push(net);
            }
        }
    }
    printf("-1\n");
}
int main()
{
    while(~scanf("%d%d",&m,&n)&&(m+n))
    {
        for(int i=0;i<m;i++)
        {
            scanf("%s",a[i]);
            for(int j=0;j<n;j++)
                if(a[i][j]=='Y')
                    now.x=i,now.y=j,now.time=0;
        }
        bfs();
    }
}

错误思路的代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
const int N=303;
char a[N][N],b[N][N];
int m,n,dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
bool vis[N][N];
struct node
{
    int x,y,time;
}now,net;
bool can(int x,int y)
{
    if(x<0||x>=m||y<0||y>=n||vis[x][y]||a[x][y]=='R'||a[x][y]=='S')
        return false;
    return true;
}
void bfs()
{
    memset(vis,false,sizeof(vis));
    queue<node>q;
    q.push(now);
    vis[now.x][now.y]=true;
    while(!q.empty())
    {
//        printf("~");
        now=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            net=now;
            net.x+=dir[i][0];
            net.y+=dir[i][1];
            if(can(net.x,net.y))
            {
                if(a[net.x][net.y]=='B')
                {
                    if(b[net.x][net.y]=='a')
                    {
                        b[net.x][net.y]='b';
                        net.x-=dir[i][0];
                        net.y-=dir[i][1];
                    }
                    else if(b[net.x][net.y]=='b')
                    {
                        net.time+=2;
                        vis[net.x][net.y]=true;
                    }
                }
                else
                {
                    vis[net.x][net.y]=true;
                    net.time++;
                }
                if(a[net.x][net.y]=='T')
                {
                    printf("%d\n",net.time);
                    return ;
                }
                q.push(net);
            }
        }
    }
    printf("-1\n");
}
int main()
{
    while(~scanf("%d%d",&m,&n)&&(m+n))
    {
        for(int i=0;i<m;i++)
        {
            scanf("%s",a[i]);
            for(int j=0;j<n;j++)
            {
                b[i][j]='a';
                if(a[i][j]=='Y')
                {
                    now.x=i,now.y=j,now.time=0;
                }
            }
        }
        bfs();
    }
}


猜你喜欢

转载自blog.csdn.net/never__give__up/article/details/80507028