Ova-10010-C++实现

  Where's Waldorf? 

Given a m by n grid of letters, and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.

Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The input begins with a pair of integers, m followed by n, in decimal notation on a single line. The next m lines contain n letters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another integer k appears on a line by itself. The next k lines of input contain the list of words to search for, one word per line. These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line in the grid where the first letter of the given word can be found (1 represents the topmost line in the grid, and m represents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found (1 represents the leftmost column in the grid, and n represents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e. the occurence which places the first letter of the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.

Sample Input 

1

8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert

Sample Output 

2 5
2 3
1 2
7 8

题目大意就是输入一个N*M的字符矩阵,然后输入一系列的单词,要你找到各个单词的首字母的行和列,行和列的输出条件要满足输出描述。单词的查找可以沿八个方向。

题目本身不难,但输出格式实在是太严格了,可能是刚接触Ova的缘故,在输出格式上捣鼓了半天。我在代码的末尾放上测试样例,读者可以根据样例的输出格式来调整自己的输出格式。

#include <iostream>
#include <string>
using namespace std;
char map[51][51];
int row,column;
bool f(int x,int y,string str)
{
    int num=str.length();
	string str1;
	for(int j=y;(j<column)&&(j<y+num);j++)//向右遍历 
	str1=str1+map[x][j];
	if(str1==str)return true;
	str1.clear();
	for(int j=y;j>=0&&j>y-num;j--)//向左遍历 
	str1=str1+map[x][j];
	if(str1==str)return true;
	str1.clear();
	for(int i=x;i<row&&i<x+num;i++)//向下遍历 
	str1=str1+map[i][y];
	if(str1==str)return true;
	str1.clear();
	for(int i=x;i>=0&&i>(x-num);i--)//向上遍历 
	str1=str1+map[i][y];
	if(str1==str)return true;
	str1.clear();
	
	for(int i=x,j=y;i>=0&&i>x-num&&j>=0&&j>y-num;i--,j--)//向左上遍历 
	str1=str1+map[i][j];
	if(str1==str)return true;
	str1.clear();
	for(int i=x,j=y;i<row&&i<x+num&&j<column&&j<y+num;i++,j++)//向右下遍历 
	str1=str1+map[i][j];
	if(str1==str)return true;
	str1.clear();
	for(int i=x,j=y;i<row&&i<x+num&&j>=0&&j>y-num;i++,j--)//向左下遍历 
	str1=str1+map[i][j];
	if(str1==str)return true;
	str1.clear();
	for(int i=x,j=y;i>=0&&i>x-num&&j<column&&j<y+num;i--,j++)//向右上遍历 
	str1=str1+map[i][j];
	if(str1==str)return true;
	str1.clear();
	return false;
} 
int main()
{
	int n;
	while(cin>>n)
	{
		for(int x=0;x<n;x++)
	    {
		    cin>>row>>column;
		    for(int i=0;i<row;i++)
		    for(int j=0;j<column;j++)
		    {
			    cin>>map[i][j];
			    if(map[i][j]>='A'&&map[i][j]<='Z')
			    map[i][j]=map[i][j]+32;//将矩阵中所有的大写字母都化为小写 
		    }
		
		    int sum;cin>>sum;
		    string str;
		    for(int i=0;i<sum;i++)
		    {
			    int minrow=51,mincolumn=51;
			    cin>>str;
			    for(int j=0;j<str.length();j++)
			    if(str[j]>='A'&&str[j]<='Z')
			    str[j]=str[j]+32;//将输入单词中所有的大写字母都化为小写 
			    for(int j=0;j<row;j++)
			    {
				    for(int k=0;k<column;k++)
			        {
				        bool temp;
				        if(map[j][k]==str[0])
			 	        {
					        temp=f(j,k,str);
					        if(temp==true)
					        {
						        minrow=min(minrow,j);
					 	        mincolumn=min(mincolumn,k);
				 	        }
				        }
			        }
			    }
			cout<<minrow+1<<' '<<mincolumn+1<<'\n';
		    }
		if(x!=n-1)
		cout<<'\n';
	   }
	}		
}
/*
2
8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
6
Waldorf 
Bambi
Betty
Dagbert
ybc
abc
8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
2
Waldorf 
Bambi
*/

猜你喜欢

转载自blog.csdn.net/achenjie/article/details/81128442