HDU-1018 Big Number

HDU-1018 Big Number

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1018

分析

题意:求一个数字阶乘的位数。首先输入一个n,表示n组测试数据,然后下面n行,一行一个数,并输出这个数字的阶乘的位数。

思路:求一个数的阶乘的位数,这就要用一个小小的数学知识了。我以前写过一个博客,关于如何求位数的,不会的可以看一下。在此附上博客链接:https://blog.csdn.net/bestfm/article/details/80100333。希望对你有帮助。

代码

#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
int main()
{
    int n,num;
    cin>>n;
    double sum;
    while (n--)
    {
        sum=0;
        cin>>num;
        for (int i=num;i>0;i--)
            sum+=log10(i);
        cout<<(int)sum+1<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/bestfm/article/details/80272877