Ananagrams

Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ. Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE. Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be “rearranged” at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line consisting of a single ‘#’.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample Input l

adder came tape soon leader acme RIDE lone Dreis peat ScAlE orb eye Rides dealer NotE derail LaCeS drIed noel dire Disk mace Rob dries #

Sample Output

Disk

NotE

derail

扫描二维码关注公众号,回复: 2328379 查看本文章

drIed

eye

ladder

soon

题目大意:

输入一些单词, 找出所有满足如下条件的单词:该单词不能通过字母的重排,得到输入文本的另外一个单词。在判断是否满足条件时,字母不分大小写,但是在输出时应保留输入中的大小写,按字典序进行排列(所有大写字母在所有小写字母的前面)。

/*
输入字符,把字符保留在一个不定数组中,再复制到另一个单独的字符串中,把字符串改造为全部小写 
储存到map中,然后计数,只要是大于一的都不是要输出的。 

*/
#include<cstdio>
#include<string> 
#include<vector> 
#include<map>
#include<iostream>
#include<algorithm>
#include<cctype>

using namespace std;

vector <string> word;
map <string, int> cnt;

string cmp (const string & s)
{
	string ans = s;
	for (int i = 0; i < s.length(); i++)
		ans[i] = tolower(ans[i]);
	sort (ans.begin(), ans.end()); //按字典序重新排列
	//单词中的字母,这样就可以排除重新排列的重复单词 
	return ans;
} // 改为小写
int main()
{
	string s;
	while (cin >> s && s != "#")
	{
		word.push_back(s);
		string r = cmp(s);
		if (!cnt.count(r)) cnt[r]= 0; // 这个是初始化 
		cnt[r] ++; 
	}
	vector<string>ans;
	for (int i = 0; i < word.size(); i++)
		if (cnt[cmp(word[i])] == 1)
			ans.push_back(word[i]);
	sort(ans.begin(), ans.end());
	for (int i = 0; i < ans.size(); i++)
		cout << ans[i] << "\n";
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/hqzzbh/article/details/81150233