poj 3692 Kindergarten

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
GB (1 ≤ GB ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input
2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0
Sample Output
Case 1: 3
Case 2: 4
题目大意:有n个女孩和m个男孩,现在给出了k个他们之间的关系,要求输出他们中最多有多少个人互相认识。
解题思路:首先算法可定是二分匹配,这就是二分匹配的问题,之后就是需要逆向思维,把没有关系的两个在矩阵中连一条边,对这些边进行二分匹配,求出最大匹配数,也就是最小覆盖数。也就是说用不认识的关系进行最小覆盖,那剩下的就是最多的认识人。
代码:
 
 
#include<stdio.h>
#include<string.h>
int a[210][210];
int v[210];
int b[210];
int m,n,k;
int fun(int u)
{
	int i;
	for(i=1;i<=n;i++)
	{
		if(!b[i]&&a[u][i])
		{
			b[i]=1;
		   if(!v[i]||fun(v[i]))
		   {
			v[i]=u;
			return 1;		
		    }
		}
	}
	return 0;
}
int main()
{
	int i,j,x,y,z,t;
	t=0;
	while(scanf("%d%d%d",&m,&n,&k),m+n+k!=0)
	{
		t++;
		for(i=0;i<=m;i++)
			for(j=0;j<=n;j++)
			 a[i][j]=1; 
		for(i=0;i<k;i++)
		{
			scanf("%d%d",&x,&y);
			a[x][y]=0;
		}
		memset(v,0,sizeof(v));
		z=0;
		for(i=1;i<=m;i++)
		{
			memset(b,0,sizeof(b));
			if(fun(i))
			 z++;
		}
		printf("Case %d: ",t);
		printf("%d\n",m+n-z);
	}
	return 0;
}
错误分析:输出的case这一行没有复制粘贴,少输出了一个空格,就光荣的pe了。

猜你喜欢

转载自blog.csdn.net/qq_39259536/article/details/79254751