POJ-1704 Georgia and Bob(NIM)

Georgia and Bob

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12208   Accepted: 4056

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 


Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

Source

POJ Monthly--2004.07.18

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
#define MAXN 1000
int a[MAXN+10];
int main()
{
    int t;
    int n;
    scanf("%d",&t);
    int i;
    while(t--)
    {
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
           scanf("%d",&a[i]);
        }
                     //奇数的情况就在0这个位置加上一个棋子
          a[0]=0;    //这个不过是棋子在棋盘中的位置的标记
        sort(a,a+n+1); //排序无论是奇数还是偶数都要进行排序
        int x=0;         //排序,因为是就近的两个棋子间的石头块,自然就是要从小到大排序
                         //额,最后一个元素的下标加1,sort 还是想讲一下。
        if(n%2==1)
        i=0;
        else
        i=1;
        for(;i<n;i+=2)
        {
            x^=(a[i+1]-a[i]-1); //(a[i+1]-a[i]+1)不就是两棋子间的石头数码?
        }
         if(x==0)        //NIM游戏原理
         printf("Bob will win\n");
         else
         printf("Georgia will win\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/81160389
BOB