hdu1796

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10101    Accepted Submission(s): 3027


 

Problem Description

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

 

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

 

Output

  For each case, output the number.

 

Sample Input

 

12 2 2 3

 

Sample Output

 

7

 

Author

wangye

 

Source

2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(4)

容斥。。。练习中。。还是有点小懵

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll a[15];
int cnt;
ll n, m;

ll gcd(ll a, ll b)
{
    return b == 0 ? a : gcd(b, a % b);
}

ll lcm(ll a, ll b)
{
    return a * b / gcd(a, b);
}

ll solve(ll x)
{
    ll ans = 0;
    for(int i = 1;i < (1<<m);i ++)
    {
        ll t = 1;
        int flag = -1;
        for(int j = 0;j < m;j ++)
        {
            if(i&(1<<j))
            {
                flag *= -1;
                t = lcm(t,a[j]);
            }
        }
        ans += flag * x / t;
    }
    return ans;
}

int main()
{
    while(~scanf("%lld%lld",&n,&m))
    {
        n --;
        cnt = 0;
        ll t;
        for(int i = 0;i < m;i ++)
        {
            scanf("%lld",&t);
            if(t)
            {
                a[cnt++] = t;
            }
        }

        cout << solve(n) <<endl;

    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Soul_97/article/details/81179781