6573: ss (石油大学, 暑假集训题)

6573: ss

时间限制: 1 Sec  内存限制: 128 MB
提交: 101  解决: 61
[提交] [状态] [讨论版] [命题人:admin]

题目描述

We will call a string that can be obtained by concatenating two equal strings an even string. For example, xyzxyz and aaaaaa are even, while ababab and xyzxy are not.
You are given an even string S consisting of lowercase English letters. Find the length of the longest even string that can be obtained by deleting one or more characters from the end of S. It is guaranteed that such a non-empty string exists for a given input.

Constraints
2≤|S|≤200
S is an even string consisting of lowercase English letters.
There exists a non-empty even string that can be obtained by deleting one or more characters from the end of S.

输入

Input is given from Standard Input in the following format:
S

输出

Print the length of the longest even string that can be obtained.

样例输入

abaababaab

样例输出

6

提示

abaababaab itself is even, but we need to delete at least one character.
abaababaa is not even.
abaababa is not even.
abaabab is not even.
abaaba is even. Thus, we should print its length, 6.

来源/分类

ABC066&ARC077 

解析:这一题没啥,减去末尾的一个,判一下是不是,是就输出此时长度,否则继续下去就好了。

#include <iostream>
#include <cstring>
using namespace std;

int main()
{
    string str;
    int len, flag, i;
    while(cin >> str){
        flag = 0;
        len = str.length();
        len--; //至少去掉一个
        if(len % 2 == 1)
            len--;
        for(i = len; i >= 2; i -= 2){
            if(!str.compare(0, i/2, str, i/2, i/2)){  //截成两半后如果相等
                //cout << i << endl;
                flag = 1;
                break;
            }
        }
        if(flag){
            cout << i << endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guihaiyuan123/article/details/81205782
ss