【二分】Drying POJ - 3104【烘干衣服】【最小化最大值】

【二分】Drying POJ - 3104

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output
Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output
sample output #1
3

sample output #2
2

题意:
有n件衣服,自然风干的速度为1单位水/s,烘干机烘干速度为k单位水/s。求最小烘干时间

思路:
烘干机比自然烘干速度快K-1
二分需要的烘干时间X,对于每一件衣服,他们都可以得到X的自然烘干,如果减去X后,仍大于0,说明光自然烘干不够,还需要烘干机,那么对于每一件衣服剩余的水量,除以烘干机可以多烘干的,得到的就是需要使用烘干机的时间,(注意向上取整)。把他们加在一起,如果和大于X,说明需要烘干机的时间超过了要求,那么这样就不行,否则可以。

AC代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <set>

using namespace std;

const int maxn = 100005;
int n, k;
long long a[maxn], ma;

bool c(long long x)
{
    if(k == 1)
    {
        if(x >= ma)
            return true;
        else
            return false;
    }
    long long t = 0;
    for(int i = 0; i < n; i++)
    {
        int cur = a[i] - x;
        if(cur > 0)
            t += (cur + k - 2) / (k - 1);
    }
    if(t > x)
        return false;
    else
        return true;
}

void sol()
{
    long long l = 0, r = ma + 1;
    while(r - l > 1)
    {
        long long mid = (r - l) / 2 + l;
        if(c(mid))
            r = mid;
        else
            l = mid;
    }
    printf("%lld\n", r);
}

int main()
{
    while(~scanf("%d", &n))
    {
        ma = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%lld", &a[i]);
            ma = max(ma, a[i]);
        }
        scanf("%d", &k);
        sol();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/floraqiu/article/details/81210071