hdu-1004

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 144665    Accepted Submission(s): 57341


 

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

 

Sample Input

 

5 green red blue red red 3 pink orange pink 0

 

Sample Output

 

red pink

 

Author

WU, Jiazhi

 

Source

ZJCPC2004

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1008 1009 1019 1021 1013 

 

Statistic | Submit | Discuss | Note

心得:不一定非要用容器做。

#include<bits/stdc++.h>
using namespace std;
char a[1002][20];
int b[1002];
int main(void)
{
    int n,i,j;
    while(~scanf("%d",&n)&&n)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(i=0;i<n;i++)
        {
            scanf("%s",a[i]);
            for(j=0;j<i;j++)
            {
                if(strcmp(a[i],a[j])==0)
                b[i]++;
            }
        }
        int t1=0,t2=b[0];
        for(i=1;i<n;i++)
        {
            if(t2<b[i]) t2=b[i],t1=i;
        }
        printf("%s\n",a[t1]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41829060/article/details/81191306