poj 2352 star(树状数组)

题目链接:http://poj.org/problem?id=2352

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题目大意:给你n个星星的位置,对于每个星星,它的等级是在他左下的星星的个数,(包括正左与正下),然后输出每个等级 的星星的个数,数据hen很大,所以用树状数组+scanf,题目有提示。

对于每个星星,因为输入是从低往高chu处输出,所以对于每个x位置的星星,ta'd它这个位置有的xi星星数一定是在它左下面的

因此可以忽略星星的y坐标

ac:

#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
//#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
#define INF 0x3f3f3f3f  
#define mod 1000000007
#define clean(a,b) memset(a,b,sizeof(a))// 水印 
ll tree[33000];//--------poj 2352
ll grade[33000];
ll n;

ll lowbit(ll i)
{
	return i&(-i);
}

void updata(ll i)
{
	while(i<=32010)
	{
		tree[i]++;
		i=i+lowbit(i);
	}
}

ll Query(ll x)
{
	ll sum=0;
	while(x>0)
	{
		sum=sum+tree[x];
		x=x-lowbit(x);
	}
	return sum;
}

int main()
{
	while(~scanf("%lld",&n))
	{
		clean(tree,0);
		clean(grade,0);
		for(int i=1;i<=n;++i)
		{
			ll x,y;
			scanf("%lld%lld",&x,&y);
			updata(x+1);
	//		for(int j=0;j<=10;++j)
	//			cout<<tree[j]<<" ";
	//		cout<<endl;
	//		cout<<Query(x+1)<<endl;
			grade[Query(x+1)]++;
			
		}
		for(int i=1;i<=n;++i)
			printf("%lld\n",grade[i]);
	}
	
}

猜你喜欢

转载自blog.csdn.net/qq_40482358/article/details/81195783