快速幂(一)

Given a positive integer N, you should output the most right digit of N^N. 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 

Output

For each test case, you should output the rightmost digit of N^N. 

Sample Input

2
3
4

Sample Output

7
6


        
  

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

        
 
#include<stdio.h>
typedef long long ll;
ll quick(ll a,ll b,int mod)
{
	ll ans=1;
	while(b)
	{
		if(b&1)
			ans=ans*a%mod;
		a=a*a%mod;
		b=b>>1;
	}
	return ans;
}
int main()
{
	
	int N;
	scanf("%d",&N);
	while(N--)
	{
		ll num;
		scanf("%lld",&num);
		int x=quick(num,num,10);	
		printf("%d\n",x);
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42173193/article/details/81208169