Train Problem II

As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

Input

The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

Output

For each test case, you should output how many ways that all the trains can get out of the railway.

Sample Input

1
2
3
10

Sample Output

1
2
5
16796

该题是求1~n 这n个数的出栈顺序的个数

卡特兰数:

这位大佬的卡特兰数讲的挺好的 >>https://blog.csdn.net/wu_tongtong/article/details/78161211 

扫描二维码关注公众号,回复: 2434652 查看本文章

稍微总结一下(引用一下):

卡特兰数的应用例子:

1,括号化问题。

2,出栈次序问题。

3,将凸多边形划分为三角形问题。

4,给顶节点组成二叉树的问题。

java:

数很大,要用java中的大数

BigInteger m = new BigInteger (String.valueOf((4*i-2)));

String.valueOf((4*i-2)) (很好很强大)

可以用上面的语句 生成 值为 4×i-2 的BigInteger 的变量m;

int a = cin.nextInt;

int 型变量的输入

arr[i] = arr[i-1].multiply(m).divide(n) ;

BigInteger 类型数据可以连续运算

import java.util.*;
import java.math.*;
public class Main {
	public static void main(String args[]){
		
		Scanner cin = new Scanner(System.in);
		BigInteger [] arr = new BigInteger [110];
		BigInteger one = new BigInteger("1");		
		arr[1]=one;
		for ( int i=2 ; i<=100 ; i++ )
		{
			BigInteger m = new BigInteger (String.valueOf((4*i-2)));
			BigInteger n = new BigInteger (String.valueOf((i+1)));
			arr[i] = arr[i-1].multiply(m).divide(n) ;
		}
		while(cin.hasNext())
		{
			int n;
			n = cin.nextInt();
			System.out.println(arr[n]);
		}		
	}
}

catalen数前20项:

1,1,2,5,14,42,132,429,1430,4862,16796,58786,208012,742900,2674440,

9694845,35357670,129644790,477638700,1767263190,

猜你喜欢

转载自blog.csdn.net/codertcm/article/details/81209142