PAT 1005 Spell It Right 翻译 分析 代码

我宣布,c++天下第一,真的是好简单,寥寥数语就把程序描绘的淋漓尽致。

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10^100^).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five
#include<iostream>
using namespace std;
int main(){
	string a; //定义字符串a
	cin>>a;    //输入字符串
	int sum = 0,i;
	for( i =0;i<a.length() ;i++)
	{
		sum+=a[i]-'0';
	}
	string s = to_string(sum); 
	string acw[10]= {"zero","one","two","three","four","five","six","seven","eight","nine"};
	cout<<acw[s[0]-'0'];
	for(i=1;i<s.length() ;i++)
	{
		cout<<" "<<acw[s[i]-'0'];
	}
	return 0;
}

 接下来写一个c版本的,各位对比一下,到底哪个更方便一点。

#include<stdio.h>
#include<string.h>
int main(){
	char a[111];
	char s[20];
	char acw[10][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
	gets(a);
	int sum = 0,i;
	int len =strlen(a);
	for(i=0;i<len;i++){
		sum+=a[i]-'0';
	}
	sprintf(s,"%d",sum);//将sum以%d的格式写入字符类型s数组中 
	printf("%s",acw[s[0]-'0']);
	for(i=1;i<strlen(s);i++)
	{
		printf(" ");
		printf("%s",acw[s[i]-'0']);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42319613/article/details/81212590