Immediate Decodability(异前置码)

Immediate Decodability

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4363    Accepted Submission(s): 2238


Problem Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
 

Input
Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
 

Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
 

Sample Input
 
  
01 10 0010 0000 9 01 10 010 0000 9
 

Sample Output
 
  
Set 1 is immediately decodable Set 2 is not immediately decodable
 

Source
 

Recommend

Eddy   |   We have carefully selected several similar problems for you:  1671 1306 2846 1314 3724 

#include<stdio.h>
#include<string.h>
using namespace std;  
int trie[100000][11], isw[100000], tot;  
int ins(char *s,int rt)  
{  
    for(int i=0;s[i];i++)  
    {  
        int x=s[i]-'0';  
        if(trie[rt][x]==0)  
            trie[rt][x]= ++tot;  
        if(isw[rt])  
            return 0;  
        rt=trie[rt][x];  
    }  
    isw[rt]=1;  
    return 1;  
}  
  
int main()  
{   
    int i,j,k,rt,lans,pa=1;  
    tot=0;  
    char ch[100];  
    rt= ++tot;  
    while(~scanf("%s",ch))  
    {  
        int ans=0;  
        ans=ins(ch, rt);  
        if(ans==0)  
            lans=1;  
        if(ch[0]=='9')  
        {    
            if(lans==1)  
                printf("Set %d is not immediately decodable\n",pa++);  
            else  
                printf("Set %d is immediately decodable\n",pa++);  
            tot=0;  
            rt=++tot;  
            memset(trie,0,sizeof(trie));  
            memset(isw,0,sizeof(isw));
		    lans=0;  
        }  
    }  
    return 0;  
}  

猜你喜欢

转载自blog.csdn.net/qq_30796379/article/details/80601815