POJ 2187 Beauty Contest(Andrew算法+旋转卡壳算法)

Beauty Contest

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 41447   Accepted: 12835

Description

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 
 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input

4
0 0
0 1
1 1
1 0

Sample Output

2

Hint

Farm 1 (0, 0) and farm 3 (1, 1) have the longest distance (square root of 2) 

Source

USACO 2003 Fall

【思路】

题目要求一群点中,最远的两点的距离。

显然不必两两计算,只需要把凸包求出来(在这里用了Andrew算法),然后旋转卡壳把最远点对的距离求出来即可。

【代码】

//******************************************************************************
// File Name: POJ_2187.cpp
// Author: Shili_Xu
// E-Mail: [email protected]
// Created Time: 2018年07月18日 星期三 22时00分53秒
//******************************************************************************

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
using namespace std;
typedef long long ll;

const double EPS = 1e-8;

int sgn(double x)
{
	if (fabs(x) < EPS) return 0;
	return (x > 0 ? 1 : -1);
}

struct point {
	int x, y;

	point(int _x = 0, int _y = 0) : x(_x), y(_y) {}
	
	bool operator<(const point &another) const
	{
		return (x < another.x) || (x == another.x && y < another.y);
	}

	bool operator==(const point &another) const
	{
		return sgn(x - another.x) == 0 && sgn(y - another.y) == 0;
	}
};

typedef point vec;

vec operator+(vec a, vec b)
{
	return vec(a.x + b.x, a.y + b.y);
}

vec operator-(point a, point b)
{
	return vec(a.x - b.x, a.y - b.y);
}

vec operator*(vec a, double p)
{
	return vec(a.x * p, a.y * p);
}

vec operator/(vec a, double p)
{
	return vec(a.x / p, a.x / p);
}

int dot(vec a, vec b)
{
	return a.x * b.x + a.y * b.y;
}

int det(vec a, vec b)
{
	return a.x * b.y - a.y * b.x;
}

int length2(vec a)
{
	return dot(a, a);
}

struct line {
	point s, e;

	line() {}
	line(point _s, point _e) : s(_s), e(_e) {}
};

struct polygon {
	vector<point> p;
	
	polygon() {}
	polygon(vector<point> v)
	{
		p = v;
	}
};

polygon convex_hull(vector<point> all)
{
	polygon ans;
	vector<point> &v = ans.p;
	sort(all.begin(), all.end());
	for (int i = 0; i < all.size(); i++) {
		while (v.size() > 1 && sgn(det(v.back() - v[v.size() - 2], all[i] - v[v.size() - 2])) <= 0)
			v.pop_back();
		v.push_back(all[i]);
	}
	int k = v.size();
	for (int i = all.size() - 2; i >= 0; i--) {
		while (v.size() > k && sgn(det(v.back() - v[v.size() - 2], all[i] - v[v.size() - 2])) <= 0)
			v.pop_back();
		v.push_back(all[i]);
	}
	if (all.size() > 1) v.pop_back();
	return ans;
}

int rotating_calipers(polygon ch)
{
	int ans = 0;
	int cur = 1, sz = ch.p.size();
	for (int i = 0; i < sz; i++) {
		vec v = ch.p[i] - ch.p[(i + 1) % sz];
		while (sgn(det(v, ch.p[(cur + 1) % sz] - ch.p[cur])) < 0)
			cur = (cur + 1) % sz;
		ans = max(ans, max(length2(ch.p[i] - ch.p[cur]), length2(ch.p[(i + 1) % sz] - ch.p[(cur + 1) % sz])));
	}
	return ans;
}

int n;
vector<point> all;
polygon ch;

int main()
{
	scanf("%d", &n);
	for (int i = 1; i <= n; i++) {
		int x, y;
		scanf("%d %d", &x, &y);
		all.push_back(point(x, y));
	}
	ch = convex_hull(all);
	printf("%d\n", rotating_calipers(ch));
	return 0;
}

猜你喜欢

转载自blog.csdn.net/shili_xu/article/details/81106964