HDU6047-Maximum Sequence(单调队列)

Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2442 Accepted Submission(s): 1153

Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1…a2n. Just like always, there are some restrictions on an+1…a2n: for each number ai, you must choose a number bk from {bi}, and it must satisfy ai≤max{aj-j│bk≤ j < i }, and any bk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{∑2nn+1ai} modulo 109+7 .

Now Steph finds it too hard to solve the problem, please help him.

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.

Output
For each test case, print the answer on one line: max{∑2nn+1ai} modulo 109+7。

Sample Input
4
8 11 8 5
3 1 4 2

Sample Output
27
Hint

For the first sample:
1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9;
2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;
题目:HDU6047
题意:题意比较绕,给你两个数组a,b,长度为n,现在要求你生成一个有最大和的a[n+1]~a[2*n],限制为
ai≤max{aj-j│bk≤j < i},即生成的ai=max{a[j]-j},(bk<=j< i),即生成的a[i]为已有的a的值减去其坐标的最大值,区间上限为i,区间下限为bk,bk可以随意在b数组里选择,但是每个数只能用一次。
思路:读懂了题,那么就是单调队列没跑了,对于每次生成ai,我们要尽量保证下限bk小,这样我们就可以生成更大的ai,贪心,维护答案即可。

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<set>
#define met(s,k) memset(s,k,sizeof s)
#define scan(a) scanf("%d",&a)
#define scanl(a) scanf("%lld",&a)
#define scann(a,b) scanf("%d%d",&a,&b)
#define scannl(a,b) scanf("%lld%lld",&a,&b)
#define scannn(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define prin(a) printf("%d\n",a)
#define prinl(a) printf("%lld\n",a)
using namespace std;
typedef long long ll;
const int maxn=1e6;
const int mod=1000000007;
ll n,head,tail,sum;
ll b[maxn];
struct node
{
    ll x,pos;
}queues[2*maxn],a[2*maxn];
void init()
{
    sum=0;
}
void get_min()//单调队列
{
    head=0;
    tail=-1;
    for(int i=1;i<2*n;i++)
    {
        while(tail>=head&&queues[tail].x<a[i].x-a[i].pos)tail--;//维护a[i].x-a[i].pos的降序队列
        queues[++tail]=a[i];
        queues[tail].x=a[i].x-a[i].pos;
        if(i>=n)while(queues[head].pos<b[i-n])head++;
        if(i>=n)a[i+1].x=queues[head].x,a[i+1].pos=i+1,sum+=a[i+1].x;
        sum%=mod;
    }
}

int main()
{
    while (~scanl(n))
    {
        init();
        for (int i = 1; i <= n; i++)scanl(a[i]), a[i].pos = i;
        for (int i = 0; i < n; i++)scanl(b[i]);
        sort(b, b + n);
        get_min();
        prinl(sum);
    }
    return  0;
}

猜你喜欢

转载自blog.csdn.net/swust5120160705/article/details/79241382