Keywords Search (AC自动机)

题目:https://vjudge.net/contest/243048#problem/I

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc. 
Wiskey also wants to bring this feature to his image retrieval system. 
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched. 
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match. 

Input

First line will contain one integer means how many cases will follow by. 
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000) 
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50. 
The last line is the description, and the length will be not longer than 1000000. 

Output

Print how many keywords are contained in the description.

Sample Input

1
5
she
he
say
shr
her
yasherhs

Sample Output

3

AC自动机模板题;

#include <iostream>
#include <stdio.h>
#include <queue>
#include <string.h>
#define maxn 1000010
#define maxm 10010
using namespace std;

struct Trie
{
    int Next[maxn/2][26],fail[maxn/2],end[maxn/2];
    int root,L;
    int newnode(){
        for(int i=0;i<26;i++)
            Next[L][i]=-1;
        end[L++]=0;
        return L-1;
    }
    void init()
    {
        L=0;
        root=newnode();
    }
    void insert(char buf[])
    {
        int len =strlen(buf);
        int now=root;
        for(int i=0;i<len;i++)
        {
            if(Next[now][buf[i]-'a']==-1)
                Next[now][buf[i]-'a']=newnode();
            now=Next[now][buf[i]-'a'];
        }
        end[now]++;
    }
    void build(){
        queue<int>Q;
        fail[root]=root;
        for(int i=0;i<26;i++)
            if(Next[root][i]==-1)Next[root][i]=root;
        else {
            fail[Next[root][i]]=root;
            Q.push(Next[root][i]);
        }
        while(!Q.empty()){
            int now=Q.front();
            Q.pop();
            for(int i=0;i<26;i++)
                if(Next[now][i]==-1)
                Next[now][i]=Next[fail[now]][i];
            else {
                fail[Next[now][i]]=Next[fail[now]][i];
                Q.push(Next[now][i]);
            }
        }
    }
    int query(char buf[])
    {
        int len=strlen(buf);
        int   now=root;
        int res=0;
        for(int i=0;i<len;i++)
        {
            now=Next[now][buf[i]-'a'];
            int temp=now;
            while(temp!=root){
                res+=end[temp];
                end[temp]=0;
                temp=fail[temp];
            }
        }
        return res;
    }
    void debug(){
        for(int i=0;i<L;i++)
        {
            printf("id = %3d,fail = %3d,end = %3d,chi = [",i,fail[i],end[i]);
            for(int j=0;j<26;j++)
                printf("%2d",Next[i][j]);
            printf("]\n");
        }
    }
};
char buf[maxn];
Trie ac;
int main()
{
    int t;
    int N;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&N);
        ac.init();
        for(int i=0;i<N;i++)
        {
            scanf("%s",buf);
            ac.insert(buf);
        }
        ac.build();
        scanf("%s",buf);
        printf("%d\n",ac.query(buf));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guagua_de_xiaohai/article/details/81368680
今日推荐