HDU - 2105The Center of Gravity ————计算几何(求重心)

Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked
leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then
on,people have sovled many problems by the the theory of the Universal Gravitation. What’s more, wo also
have known every object has its Center of Gravity.
Now,you have been given the coordinates of three points of a triangle. Can you calculate the center
of gravity of the triangle?
Input
The first line is an integer n,which is the number of test cases.
Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.
The input is terminated by n = 0.
Output
For each case, print the coordinate, accurate up to 1 decimal places.
Sample Input
2
1.0 2.0 3.0 4.0 5.0 2.0
1.0 1.0 4.0 1.0 1.0 5.0
0
Sample Output
3.0 2.7
2.0 2.3


三角形重心:
A ( x 1 , y 1 ) B ( x 2 , y 2 ) C ( x 3 , y 3 )
的重心:

( x , y ) = ( x 1 + x 2 + x 3 3 , y 1 + y 2 + y 3 3 )


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;


int main()
{
    int n;
    double x1,x2,x3,y1,y2,y3;
    while(~scanf("%d",&n)&&n)
    {
        while(n--)
        {
            cin>>x1>>y1>>x2>>y2>>x3>>y3;
            double x=(x1+x2+x3)/3.0;
            double y=(y1+y2+y3)/3.0;
            printf("%.1f %.1f\n",x,y);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/81350735