PAT 1094 The Largest Generation (25)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (&lt100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (&ltN) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (&gt0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

思路:这个题用DFS是很明显的,但是一开始我没注意到题目说根固定为1,所以用dfs也不知道从哪里开始搜》。。所以好好看题目,不放过任何一个死角才是关键。

程序:

#include <cstdio>
#include <iostream>
#include <vector>
#include <map>
using namespace std;
int generation[101];
map<int,vector<int> > mymap;

void dfs(int root)
{
  for(int i = 0; i < mymap[root].size(); i++)
  {
    generation[mymap[root][i]] = generation[root] + 1;
    dfs(mymap[root][i]);
  }
}
int main()
{
  int n,m;
  scanf("%d%d",&n,&m);
  for(int i = 0; i < m; i++)
  {
    int id,k;
    scanf("%d%d",&id,&k);
    for(int j = 0; j < k; j++)
    {
      int child;
      scanf("%d",&child);
      mymap[id].push_back(child);
    }
  }
  generation[1] = 1;
  dfs(1);
  int count[101] = {0};
  int max = 0;
  int max_gen = 0;
  for(int i = 1; i <= n; i++)
  {
    count[generation[i]]++;
    if(count[generation[i]] > max)
    {
      max = count[generation[i]];
      max_gen = generation[i];
    }
  }
  printf("%d %d\n",max,max_gen);
  return 0;
}

猜你喜欢

转载自blog.csdn.net/Hickey_Chen/article/details/81276409