PAT A1006

ps:本题大意是给你n个人进出的记录,要你找出来得最早的那个人和走的最晚的人

用了sort自定义排序规则,cmp1和cmp2

006 Sign In and Sign Out (25)(25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

扫描二维码关注公众号,回复: 2562968 查看本文章
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

代码:

#include <iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
struct node{
    string name;
    string arrtime;
    string leatime;
};
bool cmp1(const node&a,const node&b)
{
    int s1 = (a.arrtime[0] - '0') * 10 + (a.arrtime[1] - '0');
    int s2 = (b.arrtime[0] - '0') * 10 + (b.arrtime[1] - '0');
    int p1 =(a.arrtime[3] - '0') * 10 + (a.arrtime[4] - '0');
    int p2 = (b.arrtime[3] - '0') * 10 + (b.arrtime[4] - '0');
    int x1 = (a.arrtime[6] - '0') * 10 + (a.arrtime[7] - '0');
    int x2 = (b.arrtime[6] - '0') * 10 + (b.arrtime[7] - '0');
    if (s1 != s2)return s1 < s2;
    else
    {
        if (p1 != p2)return p1 < p2;
        else{
            return x1 < x2;
        }
    }
}
bool cmp2(const node&a, const node&b)
{
    int s1 = (a.leatime[0] - '0') * 10 + (a.leatime[1] - '0');
    int s2 = (b.leatime[0] - '0') * 10 + (b.leatime[1] - '0');
    int p1 = (a.leatime[3] - '0') * 10 + (a.leatime[4] - '0');
    int p2 = (b.leatime[3] - '0') * 10 + (b.leatime[4] - '0');
    int x1 = (a.leatime[6] - '0') * 10 + (a.leatime[7] - '0');
    int x2 = (b.leatime[6] - '0') * 10 + (b.leatime[7] - '0');
    if (s1 != s2)return s1 > s2;
    else
    {
        if (p1 != p2)return p1 > p2;
        else{
            return x1 > x2;
        }
    }
}
int main()
{
    int m;
    vector<node> tm;
    cin >> m;
    for (int i = 0; i < m; i++)
    {
        node s;
        cin >> s.name >> s.arrtime >> s.leatime;
        tm.push_back(s);
    }
    sort(tm.begin(), tm.end(),cmp1);
    auto g1 = tm.begin();
    cout << g1->name << " ";
    sort(tm.begin(), tm.end(),cmp2);
    auto g2 = tm.begin();
    cout << g1->name;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/luoshiyong123/article/details/81293507