J - Chores POJ - 1949 Chores 树形DP

J - Chores

 POJ - 1949 

Farmer John's family pitches in with the chores during milking, doing all the chores as quickly as possible. At FJ's house, some chores cannot be started until others have been completed, e.g., it is impossible to wash the cows until they are in the stalls. 

Farmer John has a list of N (3 <= N <= 10,000) chores that must be completed. Each chore requires an integer time (1 <= length of time <= 100) to complete and there may be other chores that must be completed before this chore is started. We will call these prerequisite chores. At least one chore has no prerequisite: the very first one, number 1. Farmer John's list of chores is nicely ordered, and chore K (K > 1) can have only chores 1,.K-1 as prerequisites. Write a program that reads a list of chores from 1 to N with associated times and all perquisite chores. Now calculate the shortest time it will take to complete all N chores. Of course, chores that do not depend on each other can be performed simultaneously.

Input

* Line 1: One integer, N 

* Lines 2..N+1: N lines, each with several space-separated integers. Line 2 contains chore 1; line 3 contains chore 2, and so on. Each line contains the length of time to complete the chore, the number of the prerequisites, Pi, (0 <= Pi <= 100), and the Pi prerequisites (range 1..N, of course). 

Output

A single line with an integer which is the least amount of time required to perform all the chores. 

Sample Input

7
5 0
1 1 1
3 1 2
6 1 1
1 2 2 4
8 2 2 4
4 3 3 5 6

Sample Output

23

Hint

[Here is one task schedule:

        Chore 1 starts at time 0, ends at time 5.

        Chore 2 starts at time 5, ends at time 6.

        Chore 3 starts at time 6, ends at time 9.

        Chore 4 starts at time 5, ends at time 11.

        Chore 5 starts at time 11, ends at time 12.

        Chore 6 starts at time 11, ends at time 19.

        Chore 7 starts at time 19, ends at time 23.

]

题意:有n个工作,第i个工作花费Ti时间,有k个前置工作(完成所有的前置工作才能开始工作i),问最短多长时间能完成所有工作。

思路:找出树上权值和最大的路;

           dp[i]记录到该点最大花费

           初始dp均为-1,然后让没有前置工作的dp[i]=cost【i】

           遍历点,如果dp[i]还没有求出来就记忆化搜索

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#define fora(i,a,b) for(i=a;i<b;i++)
#define fors(i,a,b) for(i=a;i>b;i--)
#define fora2(i,a,b) for(i=a;i<=b;i++)
#define fors2(i,a,b) for(i=a;i>=b;i--)
#define PI acos(-1.0)
#define eps 1e-6
#define INF 0x3f3f3f3f

typedef long long LL;
typedef long long LD;
using namespace std;
const int maxn=10000+11;
const int mod=10056;
int n;
int cost[maxn];
int tre[maxn][111];
int cou[maxn];
int dp[maxn];
void init()
{
    memset(cou,0,sizeof(cou));
    memset(dp,-1,sizeof(dp));
}
void read()
{
    init();
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&cost[i],&cou[i]);
        if(cou[i]==0)dp[i]=cost[i];
        for(int j=1;j<=cou[i];j++)
        {
            scanf("%d",&tre[i][j]);
        }
    }
}
void DFS(int t)
{
    for(int i=1;i<=cou[t];i++)
    {
        if(dp[tre[t][i]]==-1)DFS(tre[t][i]);
    }
    for(int i=1;i<=cou[t];i++)
    {
        dp[t]=max(dp[t],dp[tre[t][i]]);
    }
    dp[t]+=cost[t];
}
int main()
{
    while(~scanf("%d",&n))
    {
        read();
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            if(dp[i]==-1)DFS(i);
            ans=max(ans,dp[i]);
            
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/liyang__abc/article/details/81388172