2120 数据结构实验之链表五:单链表的拆分

数据结构实验之链表五:单链表的拆分

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

Input

第一行输入整数N;;
第二行依次输入N个整数。

Output

第一行分别输出偶数链表与奇数链表的元素个数; 
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

Sample Input

10
1 3 22 8 15 999 9 44 6 1001

Sample Output

4 6
22 8 44 6 
1 3 15 999 9 1001

Hint

扫描二维码关注公众号,回复: 2573606 查看本文章

不得使用数组!

Source


#include<stdio.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node * next;
};
int os=0,qs=0;
struct node *head1,*head2;
struct node *str (int n)//正序建链表
{
    int i;
    struct node *p,*head,*tail;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    for(i=0;i<n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
};
void pr(struct node *head)
{
    struct node *p,*tail1,*tail2;
    p=head->next;
    head1=(struct node *)malloc(sizeof(struct node));
    head2=(struct node *)malloc(sizeof(struct node));
    head1->next=NULL;
    head2->next=NULL;
    tail1=head1;
    tail2=head2;
    while(p)
    {
        if(p->data%2==0)
        {
            tail1->next=p;
            tail1=p;
            os++;
        }
        else
        {
            tail2->next=p;
            tail2=p;
            qs++;
        }
        p=p->next;
    }
    tail1->next=NULL;
    tail2->next=NULL;
}



void print (struct node *head)
{
    struct node *p;
    p=head->next;
    int s=0;
    while(p!=NULL)
    {
        if(s==0)
    {
        printf("%d",p->data);
        s=1;
    }
    else{

        printf(" %d",p->data);
    }
    p=p->next;
    }

    printf("\n");
}
int main()
{
    int n;
    struct node *h1;
    scanf("%d",&n);
    h1=str(n);
    pr(h1);
    printf("%d %d\n",os,qs);
    print(head1);
    print(head2);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/rangran/article/details/81408658