G - Arctic Network

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1

2 4

0 100

0 300

0 600

150 750

Sample Output

212.13

  • 题意概括  :

P个前哨站,s个卫星频道,任意两个前哨站都可以通过卫星频道或无线电来信,卫星频道无视距离,前哨站最大距离为d,与无线电的能量有关,每个前哨站的能量相同,问在所有前哨站都可以直接或间接通信的情况下,最小的d是多少。

  • 解题思路  :

n个前哨站最小生成树求出,并排序,后s-1条边使用卫星,那么剩余边中最大的边长即为d,然后问题就转化成了求第k大边的问题。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>

using namespace std;

double map[510][510],dis[550],book[550],d[550];
int x[550],y[550];
int n,s,p,inf = 99999999;

double prim()
{
	int i,j,k,count = 0;
	double min;
	memset(book,0,sizeof(book));
	
	for(i = 1;i<=p;i ++)
	{
		dis[i] = map[1][i];
	}
	book[1] = 1;
	count ++;
	while(count < p)
	{
		min = inf;
		j = 0;
		for(i = 1;i<=p;i ++)
		{
			if(book[i] == 0&&dis[i] < min)
			{
				min = dis[i];
				j = i;
			}
		}
		book[j] = 1;
		d[count] = min;
		count ++;
		for(k = 1;k<=p;k ++)
		{
			if(book[k] == 0&&dis[k] > map[j][k])
			{
				dis[k] = map[j][k];
			}
		}
	}
	sort(d+1,d+p);
	return d[p-s];
}
int main()
{
	int i,j,k;
	
	scanf("%d",&n);
	while(n --)
	{
		scanf("%d %d",&s,&p);
		for(i = 1;i<=p;i ++)
		{
			scanf("%d %d",&x[i],&y[i]);
		}
		for(i = 1;i<=p;i ++)
		{
			for(j = i+1;j<=p;j ++)
			{
				if(i == j)
				map[i][j] = 0;
				else
				map[i][j] = map[j][i] = sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
			}
		}
		printf("%.2f\n",prim());
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81333195