hdu1023

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11174    Accepted Submission(s): 5923


 

Problem Description

As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

 

Input

The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

 

Output

For each test case, you should output how many ways that all the trains can get out of the railway.

扫描二维码关注公众号,回复: 2596453 查看本文章

 

Sample Input

 

1 2 3 10

 

Sample Output

 

1 2 5 16796

Hint

The result will be very large, so you may not process it by 32-bit integers.

 

Author

Ignatius.L

卡特兰数应用  (板子)   直接用java大整数了   不知道python可不可以。。。

公式:

è¿éåå¾çæè¿°

递推式: h(n)=h(n-1)*(4*n-2)/(n+1);


import java.io.*;
import java.math.*;
import java.util.*;

public class Main {
	
	public static void main(String[] args){
		
		Scanner sc = new Scanner(System.in);
		
		BigInteger s[] = new BigInteger[105];
		
		s[1] = BigInteger.ONE;
		
		for(int i = 2;i < 105;i ++){
			
			s[i] = s[i-1].multiply(BigInteger.valueOf(4 * i - 2)).divide(BigInteger.valueOf(i + 1));
				
		}
		while(sc.hasNext()){
			
			int n =  sc.nextInt();
			System.out.println(s[n]);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/Soul_97/article/details/81384951