POJ2367 Genealogical tree【拓扑排序】

Genealogical tree

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7363   Accepted: 4765   Special Judge

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

Source

Ural State University Internal Contest October'2000 Junior Session

扫描二维码关注公众号,回复: 2597312 查看本文章

问题链接POJ2367 Genealogical tree

问题简述:(略)

问题分析

  这是一个拓扑排序的裸题,按照拓扑排序算法计算即可。

  这里采用邻接矩阵(二维数组)存储图。一般而言,只有节点规模小的情况下,图才可以使用邻接矩阵表示,不然就太费存储了。

程序说明

  下标为0的存储单元没有使用,浪费了存储,代码的下标转换不用做了,代码相对简洁。

  需要注意数据输入格式。

题记:(略)

参考链接:(略)

AC的C++语言程序如下:

/* POJ2367 Genealogical tree */

#include <iostream>
#include <string.h>

using namespace std;

const int N = 100;
int n, g[N + 1][N + 1], din[N + 1], ans[N + 1];

void toposort()
{
    for(int i = 1; i <=n; i++) {
        int j;
        for(j = 1; j <= n; j++) {
            if(din[j] == 0)
                break;
        }
        din[j] = -1;
        ans[i] = j;
        // 对于已经输出的节点j,与之有边相连的节点的入度减1
        for(int k = 1; k <= n; k++) {
            if(g[j][k])
                din[k]--;
        }
    }
}

int main()
{
    ios::sync_with_stdio(false);
    while(cin >> n) {
        memset(g, 0, sizeof(g));        // 图邻接矩阵
        memset(din, 0, sizeof(din));    // 节点入度

        // 读入图
        for(int i = 1; i <= n; i++) {
            int a;
            while(cin >> a && a) {
                g[i][a] = 1;    // 标记边
                din[a]++;       // 入度统计
            }
        }

        // 拓扑排序
        toposort();

        // 输出结果
        for(int i = 1; i < n; i++)
            cout << ans[i] << " ";
        cout << ans[n] << endl;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/81262208