1028广度优先遍历应用

Catch That Cow
Time Limit: 2000 ms Memory Limit: 65536 KiB

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
poj3278 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source
think:
一个for循环进行分类讨论,广度优先遍历,直到找到了那个牛的位置就停止;
广度优先遍历是利用了队列的,先访问当前的节点,然后把相邻的所有节点都入队,之前是for循环进行列举,现在这个题是走相应规则的路,看看有没有访问过没有的话 就入队;

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
using namespace std;
int book[1000001],step[1000001];
queue<int>q;
int k,n;
int  bfs(int s,int k)
{
    int next;
    book[s]=1;
    step[s]=0;
    q.push(s);
    while(!q.empty())
    {
        int t=q.front();
        q.pop();
        for(int i=1; i<=3; i++)
        {
            if(i==1)next=t+1;
            else if(i==2)next=t-1;
            else next=t*2;
            if(next<0||next>1000001)continue;
            if(book[next]==0)
            {
                step[next]=step[t]+1;
                book[next]=1;
                q.push(next);
            }
            if(next==k)return step[next];
        }
    }
}
int main()
{
    scanf("%d%d",&n,&k);
    memset(book,0,sizeof(book));
    memset(step,0,sizeof(step));
//    step[n]=0;
//    book[n]=1;
//    q.push(n);
    if(n>=k)printf("%d\n",n-k);
    else
    {
       printf("%d\n",bfs(n,k));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/BHliuhan/article/details/81366642