G - A Bug's Life(并查集 判断集合是否相交)

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2

3 3

1 2

2 3

1 3

4 2

1 2

3 4

Sample Output

Scenario #1:

Suspicious bugs found!

 

Scenario #2:

No suspicious bugs found!

 

 

        

  

Hint

Huge input,scanf is recommended.

        

 

  • 题意概括  :

虫子交配,判断有没有同性。

  • 解题思路  :

a加入B集合中,将b加入A集合中,即a与b+n相结合,b与a+n

相结合,最后判断集合中有没有矛盾的数据,如果有则有bug否则没有bug。

#include<stdio.h>
#include<string.h>

int f[4040];
int n,m;

int getf(int v)
{
	if(f[v] < 0)
	return v;
	return f[v] = getf(f[v]);
}

int merge(int v,int u)
{
	int t1,t2;
	
	t1 = getf(v);
	t2 = getf(u);
	
	if(t1!=t2)
	{
		f[t1] = t2;
	}
}
int main()
{
	int T,t=0,i,j,a,b,flag;
	
	scanf("%d",&T);
	while(T --)
	{
		t ++;
		memset(f,-1,sizeof(f));
		flag = 0;
		
		scanf("%d %d",&n,&m);
		
		for(i = 1;i<=m;i ++)
		{
			scanf("%d %d",&a,&b);
			merge(a,b+n);
			merge(b,a+n);
			
			if(getf(a) == getf(a+n)||getf(b) == getf(b+n))
			flag = 1;
		}
		printf("Scenario #%d:\n",t);
		if(flag == 1)
		printf("Suspicious bugs found!\n\n");
		else
		printf("No suspicious bugs found!\n\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81511846