SDUT2134数据结构实验之栈与队列四:括号匹配

数据结构实验之栈与队列四:括号匹配

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

 给你一串字符,不超过50个字符,可能包括括号、数字、字母、标点符号、空格,你的任务是检查这一串字符中的( ) ,[ ],{ }是否匹配。

Input

 输入数据有多组,处理到文件结束。

Output

 如果匹配就输出“yes”,不匹配输出“no”

Sample Input

sin(20+10)
{[}]

Sample Output

yes
no

Hint

Source

ma6174


注意:有一对不匹配就输出no

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char a[55],b[55];
int main()
{
    int i;
    while(gets(a))
    {
        int top=0;
        for(i=0; i<strlen(a); i++)
        {
            if(a[i]=='('||a[i]=='['||a[i]=='{')
               b[++top]=a[i];
            if(a[i]==')'||a[i]==']'||a[i]=='}')
            {
                if((b[top] == '(' && a[i] == ')') || (b[top] == '[' && a[i] == ']') || (b[top] == '{' && a[i] == '}'))
                    top--;
                else
                    break;
            }
        }
        if(top==0&&i==strlen(a))
            printf("yes\n");
        else
            printf("no\n");

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/rangran/article/details/81515293