sdut_2088_数据结构实验之栈与队列十一:refresh的停车场

数据结构实验之栈与队列十一:refresh的停车场

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

 refresh最近发了一笔横财,开了一家停车场。由于土地有限,停车场内停车数量有限,但是要求进停车场的车辆过多。当停车场满时,要进入的车辆会进入便道等待,最先进入便道的车辆会优先

进入停车场,而且停车场的结构要求只出去的车辆必须是停车场中最后进去的车辆。现告诉你停车场容量N以及命令数M,以及一些命令(Add num 表示车牌号为num的车辆要进入停车场或便道,

Del 表示停车场中出去了一辆车,Out 表示便道最前面的车辆不再等待,放弃进入停车场)。假设便道内的车辆不超过1000000.

Input

 输入为多组数据,每组数据首先输入N和M(0< n,m <200000),接下来输入M条命令。

Output

 输入结束后,如果出现停车场内无车辆而出现Del或者便道内无车辆而出现Out,则输出Error,否则输出停车场内的车辆,最后进入的最先输出,无车辆不输出。

Sample Input

2 6
Add 18353364208
Add 18353365550
Add 18353365558
Add 18353365559
Del
Out

Sample Output

18353365558
18353364208

Hint

Source

注意事项:如果出现停车场内无车辆而出现Del或者便道内无车辆而出现Out,则需要     最后    输出Error。

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

long long int s[200020];  //需要定义全局变量
long long int q[200020];

int main()
{
    int n, m;
    long long int x;
    while(~scanf("%d%d", &n, &m))
    {
        char st[5];
        int top = 0;
        int head = 1;
        int tail = 1;
        int flag = 0;
        while(m--)
        {
            scanf("%s", st);
            if(strcmp(st, "Add") == 0)
            {
                getchar();
                scanf("%lld", &x);
                if(top < n)
                {
                    s[++top] = x;
                }
                else
                {
                    q[tail] = x;
                    tail++;
                }
            }
            else if(strcmp(st, "Del") == 0)
            {
                if(top == 0)
                {
                    flag = 1;
                }
                else
                {
                    top--;
                    if(tail - head > 0)
                    {
                        s[++top] = q[head];
                        head++;
                    }
                }
            }
            else
            {
                if(tail - head == 0)
                {
                    flag = 1;
                }
                else
                {
                    head++;
                }
            }
        }
        if(flag)
            printf("Error\n");
        else
        {
            while(top > 0)
            {
                printf("%lld\n", s[top]);
                top--;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/strongerXiao/article/details/81362806