HDU 3038 How Many Answers Are Wrong 区间并查集

TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

题意:

TT和FF做一个很无聊的游戏, 这个游戏就是TT从序列中取出一个连续序列, 然后让FF说出这个序列之和, 然后问FF说错几个。

思路:
就是一个区间并查集。

建立区间的时候, 可以以左区间-1来无形的实现区间的合并。

然后先判断两个数的根节点是否相同, 如果不相同, 那么就进行合并。 如果相同, 那么就让大的减小的, 看看与所给分数是否相同, 如果不相同那么就是错误答案。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=200005;
int n,m;
int a[maxn];
int score[maxn];
void init(int ww)
{
    for (int i=1;i<=ww;i++)
    {
        a[i]=i;
        score[i]=0;
    }
}
int finds (int x)
{
    int temp=a[x];
    if(a[x]==x)
        return x;
    int par=finds(a[x]);
    score[x]=score[temp]+score[x];
    a[x]=par;
    return par;
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init(n);
    int num=0;
    for (int i=0;i<m;i++)
    {
        int x,y,tscore;
        scanf("%d%d%d",&x,&y,&tscore);
        if(x>y)
            swap(x,y);
        x--;
        int temp1=finds(x);
        int temp2=finds(y);
        if(temp1==temp2)
        {
            if(score[y]-score[x]!=tscore)
                    num++;
        }
        else
        {
            a[temp2]=temp1;
            score[temp2]=score[x]+tscore-score[y];
        }
    }
    printf("%d\n",num);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81583418