Doing Homework again (贪心)

Doing Homework again 

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 

Output

For each test case, you should output the smallest total reduced score, one line per test case. 

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

题目大意:

小明有n项作业,完成一门作业需要一天,然后有两行数据,第一行是每项作业交的最晚时间,第二行是每一项作业如果完不成小明就要被扣的分数,问小明最少被扣多少分

思路:从扣分多的开始写

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int d,f;
}a[1005];
bool cmp(node a,node b)
{
    if(a.f==b.f)
    return a.d<b.d;
    return a.f>b.f;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i].d);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i].f);
        sort(a,a+n,cmp);
        int vis[1005]={0},flag=0,k,sum=0;
        for(int i=0;i<n;i++)
        {
            flag=0;
            k=a[i].d;
            while(k--)
            {
                if(!vis[k])
                {
                    vis[k]=1;
                    flag=1;
                    break;
                }
            }
            if(!flag)
                sum+=a[i].f;
        }
        printf("%d\n",sum);
    }
    return 0;
}

代码:

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/81774346