平衡的括号

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a) if it is the empty string

(b) if A and B are correct, AB is correct,

(c) if A is correct, (A) and [A] is correct.

    Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input

The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string a line.

Output

A sequence of ‘Yes’ or ‘No’ on the output file.

Sample Input

3

([])

(([()])))

([()[]()])()

Sample Output

Yes

No

Yes

#include<iostream>
#include<stack>
#include<cstring>
using namespace std;
int main()
{
	int t;
	cin>>t;
	getchar();//吸收空行
	while(t--)
	{
		stack<char> q;
		int flag=1;
		string s;
		getline(cin,s);//有空串,必须按行输入
		for(int i=0;i<s.size();i++)
		{
		    if(s[i]=='('||s[i]=='[')
		        q.push(s[i]);
	    	else if(s[i]==')'&&!q.empty()&&q.top()=='(')//注意q.top条件必须在最后
		        q.pop();
	     	else if(s[i]==']'&&!q.empty()&&q.top()=='[')
	            q.pop();
	        else flag=0;
	    }
		if(flag&&q.empty())cout<<"Yes"<<endl;
		else cout<<"No"<<endl;
		while(!q.empty()) q.pop();//清空栈
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/wwwwcw/article/details/81566002