POJ2485 Highways——————最小生成树

Highways

Language:Default
Highways
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36401 Accepted: 16286

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They’re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU

给的是图的邻接矩阵
第 i 行,j 列表示 i 到 J 的距离


//#include<bits/stdc++.h>
#include<cstdio>
#include<vector>
#include<algorithm>

using namespace std;
const int MAXN=505;
int n,m,pre[MAXN];
struct Edge{
    int x,y,dis;
    Edge(){}
    Edge(int x1,int y1,int dis1)
    {
        x=x1; y=y1; dis=dis1;
    }
};
bool cmp(Edge a,Edge b)
{
    return a.dis<b.dis;
}
vector<Edge>d;
void init(){for(int i=1;i<=n;i++) pre[i]=i; }
int find(int x){return pre[x]==x?x:pre[x]=find(pre[x]); }
bool join(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y)
    {
        pre[x]=y;
        return true;
    }
    return false;
}


int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        d.clear();
        scanf("%d",&n);
        init();
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                int x;
                scanf("%d",&x);
                if(i==j)    continue;
                d.push_back(Edge(i,j,x));
            }
        sort(d.begin(),d.end(),cmp);
        int cnt=0,ans=0;
        for(int i=0;i<d.size();i++)
        {
            Edge e=d[i];
            if(join(e.x,e.y))
            {
                cnt++;
                ans=max(ans,e.dis);
            }
            if(cnt==n-1) break;
        }
        printf("%d\n",ans);
    }
    return 0;
}





















猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/81749805