[ PAT-A ] 1035 Password (C++)

题目描述

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line “There are N accounts and no account is modified” where N is the total number of accounts. However, if N is one, you must print “There is 1 account and no account is modified” instead.

Sample Input 1:
3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:
2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:
1
team110 abcdefg332

Sample Output 2:
There is 1 account and no account is modified

Sample Input 3:
2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:
There are 2 accounts and no account is modified


解题思路

题目大意
给定用户名和密码,判断密码是否合乎标准,若如不符,则需要将其转换成对应的标准形式,并输出
思路
字符串处理。对密码进行遍历,若如发现需要更换的字符,将其换成对应的标准形式并记录下结果


代码设计
//AC代码
//zhicheng
#include<cstdio>
#include<iostream>
#include<vector>
using namespace std;
// zhicheng
// August 17,2018
vector<string> re;
int main()
{
    // freopen("1.in","r",stdin);
    int t,count=0,numb;
    for(scanf("%d",&t),numb=t;t;t--)
    {
        int cnt=0;bool flg=false;
        string id,pw; cin>>id>>pw;//输入用户名和密码
        while(pw[cnt]!='\0') 
        {
            switch(pw[cnt])
            {// 如若出现以下字符,将其转换成对应的标准形式
                case '1': pw[cnt]='@';flg=true;break;
                case '0': pw[cnt]='%';flg=true;break;
                case 'l': pw[cnt]='L';flg=true;break;
                case 'O': pw[cnt]='o';flg=true;break;
            }
            cnt++;
        }
        if(flg) {count++;re.push_back(id+" "+pw);}//如若本次密码存在不符,记录下用户名和修改后的密码
    }
    if(count==0)
        if(numb<=1) printf("There is 1 account and no account is modified\n");
        else printf("There are %d accounts and no account is modified\n",numb);
    else{
        printf("%d\n",count);
        for(int i=0;i<count;i++)
            printf("%s\n",re[i].c_str());
    } 
    re.clear();
    return 0;
}


有关PAT (Basic Level) 的更多内容可以关注 ——> PAT-B题解


有关PAT (Advanced Level) 的更多内容可以关注 ——> PAT-A题解

铺子日常更新,如有错误请指正
传送门:代码链接 PTA题目链接 PAT-A题解

猜你喜欢

转载自blog.csdn.net/S_zhicheng27/article/details/81783540