矩形类定义

问题 A: 熟悉题型——类设计( 矩形类定义【C++】)

时间限制: 1 Sec   内存限制: 128 MB
提交: 383   解决: 211
[ 提交][ 状态][ 讨论版]

题目描述

定义一个矩形类,数据成员包括左下角和右上角坐标,定义的成员函数包括必要的构造函数、输入坐标的函数,以及计算并输出矩形面积的函数。要求使用提示中给出的测试函数并不得改动。

输入

四个数,分别表示矩形左下角和右上角顶点的坐标,如输入3.7 0.4 6.5 4.9,代表左下角坐标为(3.7, 0.4),右上角坐标为(6.5, 4.9)。

请根据给出的主函数,完成矩形类设计。

输出

输出一共有3行(请参考提示(hint)中的main函数):
第一行:由输入的坐标确定的矩形对象p1的面积
第二行:由对象复制得到的矩形对象p2的面积
第三行:直接初始化得到的矩形对象p3的面积

样例输入

3.7 0.4 6.5 4.9

样例输出

12.6
12.6
10

提示

int main()



{



Rectangle p1;



p1.input();



p1.output();



Rectangle p2(p1);



p2.output();



Rectangle p3(1,1,6,3);



p3.output();



return 0;



}


#include <iostream>
#include <cmath>
using namespace std;
class Rectangle
{
private:
    double x1,y1,x2,y2;
public:
    Rectangle()
    {
        x1=x2=y1=y2=0;
    }
    Rectangle(double x,double y,double xx,double yy):x1(x),y1(y),x2(xx),y2(yy){}
    void input()
    {
        cin>>x1>>y1>>x2>>y2;
    }
    void output()
    {
        cout<<fabs(x1-x2)*fabs(y1-y2)<<endl;
    }
};


int main()


{


Rectangle p1;


p1.input();


p1.output();


Rectangle p2(p1);


p2.output();


Rectangle p3(1,1,6,3);


p3.output();


return 0;


}

猜你喜欢

转载自blog.csdn.net/qq_41903671/article/details/80801586