[Java] 1015. Reversible Primes (20)-PAT甲级

1015. Reversible Primes (20)
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
题目大意:如果一个数本身是素数,而且在d进制下反转后的数在十进制下也是素数,就输出Yes,否则就输出No

PS:感谢github用户@fs19910227提供的pull request~

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.math.BigInteger;

public class Main {
    private boolean isPrime(String number) {
        int value = Integer.valueOf(number);
        if (value <= 1) return false;
        if (value == 2) return true;
        if (value % 2 == 0) return false;
        int maxLimit = (int) Math.sqrt(value);
        for (int i = 3; i <= maxLimit; i += 2) {
            if (value % i == 0) {
                return false;
            }
        }
        return true;
    }

    private String reversePrime(String number, int radix) {
        int value = Integer.valueOf(number);
        StringBuilder builder = new StringBuilder();
        for (; value != 0; value = value / radix) {
            int bit = value % radix;
            builder.append(bit);
        }
        return new BigInteger(builder.toString(), radix).toString();
    }

    public static void main(String[] args) throws IOException {
        BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
        Main rp = new Main();
        String[] split = reader.readLine().split(" ");
        for (; split.length > 1; split = reader.readLine().split(" ")) {
            String number = split[0];
            int radix = Integer.valueOf(split[1]);
            if (rp.isPrime(number) &&
                    rp.isPrime(rp.reversePrime(number, radix))) {
                System.out.println("Yes");
            } else {
                System.out.println("No");
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/liuchuo/article/details/81436603