HDU1710二叉树后序遍历

Problem Description

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.
In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.
In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.
In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.
Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.

Input

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.

Output

For each test case print a single line specifying the corresponding postorder sequence.

Sample Input

9

1 2 4 7 3 5 8 9 6

4 7 2 1 8 5 9 3 6

Sample Output

7 4 2 8 9 5 6 3 1

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1710

#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;
/*本程序根据二叉树的前序遍历序列和中序遍历序列,找出后续遍历序列*/
const int N=1005;
typedef struct tree{
int x;
tree *l,*r;
}tree;
tree *root;
tree *create(int *a,int *b,int n)
{
    tree *root;
    for(int i=0;i<n;i++)
    {
        if(a[0]==b[i])//先序遍历的第一个元素就是头节点元素,那么在中序遍历中找到相同的值b[i]停止,那么b[0]~b[i-1]都是左子树节点
        {
            root=(tree*)malloc(sizeof(tree));
            root->x=a[0];
            root->l=create(a+1,b,i);//进一步寻找左子树的根节点
            root->r=create(a+i+1,b+i+1,n-i-1);//寻找右子树的根节点
            return root;
        }
    }
    return NULL;
}
void traversal(tree *s)
{
    if(s)
    {
        traversal(s->l);
        traversal(s->r);
        if(s!=root)
        {
            cout<<s->x<<" ";
        }
        else
        {
            cout<<s->x<<endl;
        }
    }
}
int main()
{
    int n;
    int a[N],b[N];
    while(cin>>n)
    {
        root=NULL;
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&b[i]);
        }
        root=create(a,b,n);
        traversal(root);
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/salmonwilliam/article/details/81263076