PAT-1026 Table Tennis

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/eric4784510/article/details/82023809

1026 Table Tennis (30)(30 分)

A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.

Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.

One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (<=10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players' info, there are 2 positive integers: K (<=100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.

Output Specification:

For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.

Sample Input:

9
20:52:00 10 0
08:00:00 20 0
08:02:00 30 0
20:51:00 10 0
08:10:00 5 0
08:12:00 10 1
20:50:00 10 0
08:01:30 15 1
20:53:00 10 1
3 1
2

Sample Output:

08:00:00 08:00:00 0
08:01:30 08:01:30 0
08:02:00 08:02:00 0
08:12:00 08:16:30 5
08:10:00 08:20:00 10
20:50:00 20:50:00 0
20:51:00 20:51:00 0
20:52:00 20:52:00 0
3 3 2

 模拟排队,没什么难的,考试需要一个小时左右写出来,能做对主要是靠体力。

#include<stdio.h>
#include<vector>
#include<math.h>
#include<algorithm>
using namespace std;
typedef struct player{
	int hour,min,sec;
	int servesec;
	int playing;//min
	bool vip;
}player;
typedef struct table{
	bool available;
	bool vip;
	int remainsec,players;
}table;
int n,k,m;
table tables[105];
vector<player> list;
vector<int> que;
int getsec(player p){
	return p.hour*3600+p.min*60+p.sec;
}
bool cmp(player &p1,player &p2){
	return getsec(p1)<getsec(p2);
}
bool cmp2(player &p1,player &p2){
	return p1.servesec<p2.servesec;
}
void tableAvailable(int *all,int *vip){
	*all=0,*vip=0;
	for(int i=1;i<=k;i++){
		if(tables[i].available){
			(*all)++;
			if(tables[i].vip)
				(*vip)++;
		}
	}
}
int gettable(){
	for(int i=1;i<=k;i++){
		if(tables[i].available)
			return i;
	}
	return -1;
}
int getviptable(){
	for(int i=1;i<=k;i++){
		if(tables[i].vip&&tables[i].available)
			return i;
	}
	return -1;
}
void refreshTable(){
	for(int i=1;i<=k;i++){
		if(!tables[i].available){
			tables[i].remainsec--;
			if(tables[i].remainsec==0){
				tables[i].players++;
				tables[i].available=true;
			}
		}
	}
}
int nextvip(){
	for(int i=0;i<que.size();i++){
		if(list[que[i]].vip){
			int t=que[i];
			que.erase(que.begin()+i);
			return t;
		}
	}
	return -1;
}
int nextplayer(){
	if(que.size()>0){
		int t=que[0];
		que.erase(que.begin());
		return t;
	}
	return -1;
}
int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		player p;int tag;
		scanf("%d:%d:%d %d %d",&p.hour,&p.min,&p.sec,&p.playing,&tag);
		if(tag==1)p.vip=true;
		else p.vip=false;

		if(p.playing>120)p.playing=120;

		p.servesec=0;
		list.push_back(p);
	}
	scanf("%d %d",&k,&m);
	for(int i=1;i<=k;i++){
		tables[i].available=true;
		tables[i].vip=false;
		tables[i].players=0;
		tables[i].remainsec=0;
	}
	for(int i=0;i<m;i++){
		int t;
		scanf("%d",&t);
		tables[t].vip=true;
	}

	sort(list.begin(),list.end(),cmp);
	int nextin=getsec(list[0]);
	int next=0;
	int h0800=8*3600,h2100=21*3600;
	for(int i=h0800;i<h2100;i++){
		refreshTable();
		if(i==nextin){//someone comes
			que.push_back(next);
			if(next==n-1){nextin=-1;}
			else {next++;nextin=getsec(list[next]);	}
		}
		int all,vip;
		tableAvailable(&all,&vip);
		int vipserved=0;
		int id;
		while(vip--&&(id=nextvip())!=-1){
			int v=getviptable();
			tables[v].remainsec=list[id].playing*60;
			tables[v].available=false;
			list[id].servesec=i;
			vipserved++;
		}
		all-=vipserved;
		while(all--&&(id=nextplayer())!=-1){
			int t=gettable();
			tables[t].remainsec=list[id].playing*60;
			tables[t].available=false;
			list[id].servesec=i;
		}
	}
	//last second
	for(int i=1;i<=k;i++){
		if(!tables[i].available){	
			tables[i].players++;	
		}
	}
	sort(list.begin(),list.end(),cmp2);
	for(int i=0;i<n;i++){
		player p=list[i];
		if(p.servesec==0)
			continue;
		int h,m,s;
		h=p.servesec/3600;m=(p.servesec-3600*h)/60;
		s=p.servesec-3600*h-60*m;
		int wait=floor((p.servesec-getsec(p))/60.0+0.5f);
		printf("%02d:%02d:%02d %02d:%02d:%02d %d\n",p.hour,p.min,p.sec,h,m,s,wait);

	}
	for(int i=1;i<=k;i++){
		printf("%d",tables[i].players);
		if(i!=k)printf(" ");
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/eric4784510/article/details/82023809