1132 Cut Integer(JAVA)

1132 Cut Integer(20 分)

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​). It is guaranteed that the number of digits of Z is an even number.
Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.
Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No
题解:水题,但是有坑~
注意两点:1.0不能做除数,所以如果A,B有一个为零就要输出No。
2.substring(0,k),这个字符串中不包括k地址里的字符。

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        while(n-- > 0) {
            String s = sc.next();
            int k = s.length() / 2;
            String sa = s.substring(0, k);
            String sb = s.substring(k);
            Integer a = Integer.parseInt(sa);
            Integer b = Integer.parseInt(sb);
            if(a == 0 || b == 0)
                System.out.println("No");
            else {
                Integer c = a * b;
                Integer ss = Integer.parseInt(s);
                if(ss % c == 0)
                    System.out.println("Yes");
                else
                    System.out.println("No");
                }
            }
        sc.close();
    }
}

猜你喜欢

转载自blog.csdn.net/qq_39557517/article/details/81874400