1027 Colors in Mars(20 分)(C++)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

题目大意:十进制转换为十三进制。

#include<iostream>
using namespace std;
void p(int x){
  char y1,y2;
  if(x<13)
      y1='0';
  if(x>=13){
    int m=x/13;
    if(m<=9)
      y1=m+'0';
    else if(m==10)
      y1='A';
    else if(m==11)
      y1='B';
    else if(m==12)
      y1='C';
    x%=13;
  }
  if(x<=9)
      y2=x+'0';
  else if(x==10)
      y2='A';
  else if(x==11)
      y2='B';
  else if(x==12)
      y2='C';
  cout<<y1<<y2;
}
int main(){
  int x,y,z;
  cin>>x>>y>>z;
  cout<<'#';
  p(x);
  p(y);
  p(z);
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/82050331