NYOJ-5:Binary String Matching

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wingrez/article/details/82048987

NYOJ-5:Binary String Matching

来源:http://acm.nyist.edu.cn/JudgeOnline/problem.php?pid=5

标签:字符串,字符串匹配,KMP算法

参考资料:

相似题目:

题目

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入

The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.

输出

For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.

输入样例

3
11
1001110110
101
110010010010001
1010
110100010101011

输出样例

3
0
3

题目大意

在串B中匹配串A,输出匹配成功次数。

解题思路

利用KMP算法求解。

参考代码

#include<stdio.h>
#include<string.h>
#define MAXN 1005

char A[MAXN],B[MAXN];
int f[MAXN];
int ans;

void getFail(char *P, int *f){
    int m=strlen(P);
    f[0]=f[1]=0;//递推边界初值
    for(int i=1;i<m;i++){
        int j=f[i];
        while(j && P[i]!=P[j]) j=f[j];
        f[i+1]= P[i]==P[j]? j+1: 0;
    }
}

int find(char *T, char *P, int *f){
    int n=strlen(T),m=strlen(P);
    getFail(P,f);
    int j=0;//当前结点编号,初始为0号结点 
    for(int i=0;i<n;i++){//文本串当前指针 
        while(j && P[j]!=T[i]) j=f[j];//顺着失配边走,直到可以匹配
        if(P[j]==T[i])j++;
        if(j==m) ans++;
    }
}


int main(){
    int N;
    scanf("%d",&N);
    while(N--){
        ans=0;
        scanf("%s%s",A,B);
        find(B,A,f);
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wingrez/article/details/82048987