【HDU 1520 】Anniversary party(树形dp入门)

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16772    Accepted Submission(s): 6372


 

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

 

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

 

Output

Output should contain the maximal sum of guests' ratings.

 

Sample Input

 

7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0

 

Sample Output

 

5

第一道树形dp的题目,写一下个人对树形dp的认识,树形dp的状态转移方程一般都是根据根节点和叶子结点的关系来推导的。

对于这个题,我们用dp[i][0]代表这个人不来,dp[i][1]代表这个人来。

那么dp[i][1]+=dp[j][0]//j为i的下属。

        dp[i][0]+=max(dp[j][0],dp[j][1]);

对于一道树形dp,我们首先要做的就是先建树,在这里一般用的是邻接表法。

接下来我们要找到根节点,我们在建树的过程中记录父节点,然后倒着查询即可。

最后从根节点开始进行DFS,DFS每一个根节点的子节点,然后回溯的获得状态转移方程的值即可。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 30006;
vector<int> g[maxn];
int dp[maxn][2];
int father[maxn];
void dfs(int root)
{
    for(int i=0;i<g[root].size();i++)
    {
        dfs(g[root][i]);
    }
    for(int i=0;i<g[root].size();i++)
    {
        dp[root][1]+=dp[g[root][i]][0];
        dp[root][0]+=max(dp[g[root][i]][1],dp[g[root][i]][0]);
    }
}
int main()
{
    int n;
    while(cin>>n)
    {
        memset(father,-1,sizeof(father));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            cin>>dp[i][1];g[i].clear();
        }

        int l,k;
        while(cin>>l>>k&&(l+k))
        {
            father[l]=k;//记录父亲节点
            g[k].push_back(l);//存图
        }
        int root=1;
        while(father[root]!=-1)
        {
            root=father[root];//查找树根
        }
        dfs(root);
        cout<<max(dp[root][0],dp[root][1])<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/duanghaha/article/details/81560116