HDU6438:Buy and Resell(贪心+set+pair)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1665    Accepted Submission(s): 575


 

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:

1. spend ai dollars to buy a Power Cube
2. resell a Power Cube and get ai dollars if he has at least one Power Cube
3. do nothing

Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

 

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.

 

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

 

Sample Input

1 2 10 9

5

9 5 9 10 5

2

2 1

Sample Output

16 4

5 2

0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16 In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5 In the third case, he will do nothing and earn nothing. profit = 0

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

 思路:用set+pair保存数据并标记,扫一次,用set维护最小值,可以卖就卖,卖完还要把自己放进set。

https://blog.csdn.net/junior19/article/details/82053151,原创作者链接

#include<bits/stdc++.h>
using namespace std;

typedef long long LL;
const int maxn = 1e5+30;
multiset<pair<LL,int> >s;///后面这两个>>之间要有空格,要不然就成了移位运算符了
///multiset与set类似,不过multiset可以有重复元素,set不行
///pair<class T1,class T2>,pair 将一对值组合成一个值,分别用first和second访问

int main()
{
    int T, n;
    LL x;
    for(scanf("%d", &T);T;--T)
    {
        LL a1 = 0, a2 = 0;///总价钱,城市数量
        s.clear();///清空
        scanf("%d", &n);
        for(int i = 0;i < n; i++)
        {
            scanf("%lld", &x);
            if(s.empty())s.insert({x,1});///1为标记
            else
            {
                if((s.begin()->first) < x)///如果当前进来的值比原来的还大
                {
                    ///大了,于是我们sell
                    a1 += x-(s.begin()->first);
                    a2 += (s.begin()->second);
                    pair<LL, int>temp = *s.begin();
                    /*上面这一行
                    pair<LL,int>temp;
                    temp.first = s.begin()->first;
                    temp.second = s.begin()->second;*/
                    s.erase(s.begin());//已卖出,不再考虑
                    if(temp.second == 0)s.insert({temp.first,1});
                    ///拿样例一来说,1买进,2卖出,a1=1,把2的second标记为0
                    ///下一次进来9,再卖出,a1=1+(9-2)=8,,把二的标记改为1,
                    ///相当于我用9买了1的,然后现在2还是可以卖出的,
                    ///下一步进入10,卖出,a1 = 8+(10-2)=16
                    s.insert({x,0});
                }else
                {
                    ///当前的值比容器里的还小,那么我们buy
                    s.insert({x,1});
                }
            }
        }
        printf("%lld %lld\n", a1, a2*2);
    }
}
/*
3
4
1 2 10 9
5
9 5 9 10 5
2
2 1
*/
/*
16 4
5 2
0 0
*/


猜你喜欢

转载自blog.csdn.net/wys5wys/article/details/82118448