pta--1031 Hello World for U(20 分)(字符乱序输出&&规律)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

【分析】

题意:给你一个字符串,最大长度不超过80,让你U型输出。

思路:有题中,n​1​​+n​2​​+n​3​​−2=N. 即,a+b+c-2=N  →  2a+c=N+2  →   a=(N+2)/3 ;   c=(N+2)%3+a;  然后注意一下输出顺序就好了。题中没有提到空格怎么处理,我就没有处理,A了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int main()
{
	string s;
	cin>>s;
	int len=s.length();
	int a=(len+2)/3;
	int c=(len+2)%3+a;
	for(int i=0;i<a-1;i++)
	{
		cout<<s[i];
		for(int j=0;j<c-2;j++)cout<<' ';
		cout<<s[len-1-i]<<endl;
	}
	for(int i=a-1;i<len-a+1;i++)
		cout<<s[i];
	cout<<endl;	
	
	
 } 

猜你喜欢

转载自blog.csdn.net/qq_38735931/article/details/82146575