HDU1241 Oil Deposits(经典DFS)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_42391248/article/details/82025082

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42812    Accepted Submission(s): 24850

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

@表示油田,斜着也算连着的,连着的@算一块油田,找一共有多少块油田。

很经典的DFS题,之前写过但是在写一遍还是迷路了呀。。。虽然是个水题吧,我还是稍微剪了剪枝。先找到@的位置,然后DFS,把找到的@都改成*。

具体代码如下:

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
char map[102][102];
int d[8][2]={0,1,0,-1,-1,0,1,0,1,1,-1,-1,1,-1,-1,1};
int m,n;
void DFS(int x,int y)
{
	map[x][y]='*';
	for(int i=0;i<8;i++)
	{
		int nx=x+d[i][0];
		int ny=y+d[i][1];
		if(nx<0||ny<0||nx>=m||ny>=n)
			continue;
		if(map[nx][ny]=='@')
			DFS(nx,ny);			
	}
}
int main()
{
	while(cin>>m>>n,m&&n)
	{
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				cin>>map[i][j];
		int ans=0;	
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
			{
				if(map[i][j]=='@')
				{
					DFS(i,j);
					ans++;
				}
			}	
		cout<<ans<<endl;	
	}
	return 0;	
} 
扫描二维码关注公众号,回复: 2964144 查看本文章

猜你喜欢

转载自blog.csdn.net/qq_42391248/article/details/82025082