【HDU-5000】Clone(dp)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Coldfresh/article/details/81748274

Problem Description
After eating food from Chernobyl, DRD got a super power: he could clone himself right now! He used this power for several times. He found out that this power was not as perfect as he wanted. For example, some of the cloned objects were tall, while some were short; some of them were fat, and some were thin.

More evidence showed that for two clones A and B, if A was no worse than B in all fields, then B could not survive. More specifically, DRD used a vector v to represent each of his clones. The vector v has n dimensions, representing a clone having N abilities. For the i-th dimension, v[i] is an integer between 0 and T[i], where 0 is the worst and T[i] is the best. For two clones A and B, whose corresponding vectors were p and q, if for 1 <= i <= N, p[i] >= q[i], then B could not survive.

Now, as DRD’s friend, ATM wants to know how many clones can survive at most.

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case: The first line contains 1 integer N, 1 <= N <= 2000. The second line contains N integers indicating T[1], T[2], …, T[N]. It guarantees that the sum of T[i] in each test case is no more than 2000 and 1 <= T[i].

Output
For each test case, output an integer representing the answer MOD 10^9 + 7.

Sample Input
2
1
5
2
8 6

Sample Output
1
7
有点类似于分组dp,我们发现如果我们使得每个人的属性值的和达到所有总属性和的一半,那么我们可以保证每个人都可以存活而且数量最多,然后就是去dp了
d p [ i ] [ j ] 为考虑了前i个属性,和达到j时的种类数。
代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#define ll long long
#define mod 1000000007
using namespace std;
ll dp[2005][2005];
int T[2005];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        int n;
        scanf("%d",&n);
        int sum=0;
        for(int i=1;i<=n;i++)scanf("%d",T+i),sum+=T[i];
        sum/=2;
        dp[0][0]=1;
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<=sum;j++)
                for(int k=0;k<=T[i];k++)
                {
                    if(k>j)break;
                    dp[i][j]=(dp[i][j]+dp[i-1][j-k])%mod;
                }
        }
        printf("%lld\n",dp[n][sum]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Coldfresh/article/details/81748274