【LightOJ - 102】【Trailing Zeroes (I) 】

版权声明:本人原创,未经许可,不得转载 https://blog.csdn.net/qq_42505741/article/details/82054278

题目:

We know what a base of a number is and what the properties are. For example, we use decimal number system, where the base is 10 and we use the symbols - {0, 1, 2, 3, 4, 5, 6, 7, 8, 9}. But in different bases we use different symbols. For example in binary number system we use only 0 and 1. Now in this problem, you are given an integer. You can convert it to any base you want to. But the condition is that if you convert it to any base then the number in that base should have at least one trailing zero that means a zero at the end.

For example, in decimal number system 2 doesn't have any trailing zero. But if we convert it to binary then 2 becomes (10)2 and it contains a trailing zero. Now you are given this task. You have to find the number of bases where the given number contains at least one trailing zero. You can use any base from two to infinite.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer N (1 ≤ N ≤ 1012).

Output

For each case, print the case number and the number of possible bases where N contains at least one trailing zero.

Sample Input

3

9

5

2

Sample Output

Case 1: 2

Case 2: 1

Case 3: 1

Note

For 9, the possible bases are: 3 and 9. Since in base 39 is represented as 100, and in base 99 is represented as 10. In both bases, 9 contains a trailing zero.

题意:貌似求这个数字转换为几进制会转换为存在后缀0的存在,求解个数,实则算有多少因子。。

解题思路:你首先要明确,咱们的prime数组里边是存的什么,是存放的从小到大的素数,咱们要做的就是计算每个素数有多少个,注意注意注意,不是简单的加和,而是 +1之后做乘积,因为咱们求出来的是这个素数有多少个,然后他又可以自由组合,产生新的因子。最后还注意判断n最后是不是大于1 ,这种情况就是他的后边铁定会存在一个比n的根号下大的数,且只会有一个,为啥?因为这个数的平方都已经大于n了,之后还要有个比它还大的数,乘一下,不知道比n大好多,所以之后需要乘一下2。就酱。。

ac代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define maxn 1010105
using namespace std;
int prime[maxn];
int v[maxn];
int cnt;
void db()
{
	memset(v,0,sizeof(v));
	cnt=0;
	int i,j;
	for(i=2;i<maxn;i++)
	{
		if(!v[i])
		{
			prime[cnt++]=i;
			for(j=i*2;j<maxn;j+=i)
				v[j]=1;
		}
	}
}
int main()
{
	db();
	int t,i,j,a;
	long long n;
	int cas=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld",&n);
		long long int ans=1;
		for(i=0;i<cnt&&prime[i]*prime[i]<=n;i++)
		{
			if(n%prime[i]==0)
			{
				int ccnt=0;
				while(n%prime[i]==0)
				{
					ccnt++;
					n/=prime[i];
				}
				ans=ans*(ccnt+1);
			}
		}
		if(n>1)
			ans*=2;
		printf("Case %d: ",++cas);
		printf("%lld\n",ans-1); 
	}
	return 0;
}

 

ac代码:

猜你喜欢

转载自blog.csdn.net/qq_42505741/article/details/82054278